Jump to content

Android retrofit for premium connect.


StormtrooperZ
 Share

Recommended Posts

24 minutes ago, wvSTUwv said:

I am interested. Does the display turn off when the handbrake is released 

Sorry bud, not sure I understand your question. There's no correlation between the handbrake and the screen, so no the screen doesn't turn off when the handbrake is released.

Link to comment
Share on other sites

5 minutes ago, wvSTUwv said:

That’s good, with the original if you have a dvd playing and then start driving the screen turns off. Was just thinking that maybe google maps might turn off or something like that. 

Ah. Ok. No the system keeps running while you drive. So maps/music/torque whatever app you're running, will keep going until you turn them off.

Link to comment
Share on other sites

  • 2 weeks later...

Received my unit today and fitted it myself. I've never done any sort of install like this before it's pretty straight forward I did have to message stormtrooperz a couple of times when I was unsure of something but he responded pretty quickly and was really helpful. 

IMG_20200507_191955.jpg

IMG_20200507_192012.jpg

  • Like 3
Link to comment
Share on other sites

48 minutes ago, nissanjuke said:

BIG QUESTION will it work on my 2009 non -premium system B)

I couldn't say buddy, sorry. I'm going by what the manufacturer states, and they list the premium connect only. 

 

If someone with the older system is happy to come round mine and volunteer for a test install, I'd be happy to give it a try. That's probably the only way we'll find out. 

 

Link to comment
Share on other sites

1 hour ago, Johnski691 said:

Interested, but have 2010 non touch screen which frustrates the heck out of me!  In lincoln area and would be willing to guinea pig it ?   Do we know a rough order of price? 

Hi buddy, price is £375. But I don't think it'll work on a non touchscreen system. I'll give you a shout the next time I have a unit lying around and we can give it a try.

Link to comment
Share on other sites

Installed the unit in a 2010 40th Anniversary zed the other day. It had the premium connect, but no reversing camera.  All working well, but had to disable the rear camera view in the unit's settings to prevent it from showing the parking lines on a black screen when the car was put in reverse!

 

Also apple carplay confirmed as working via an apple dongle B)

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
On 10/06/2020 at 15:50, StormtrooperZ said:

Hi Rob. I should think so. As per my previous post above. We installed this on a 2010 car and it worked fine B)

That's good news then! :yahoo:One more question, my Z doesn't have the reverse camera installed OEM, would it be possible to plug one into this?

  • Like 1
Link to comment
Share on other sites

6 hours ago, Robz350z said:

That's good news then! :yahoo:One more question, my Z doesn't have the reverse camera installed OEM, would it be possible to plug one into this?

No. You can't plug an aftermarket camera directly into the unit. The default camera integration is via the main loom/power harness so relies on the camera being setup on the Nissan system first etc.

 

So you'd have to install the camera to the stock system first and the android unit would pick it up as part of the integration.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...