Jump to content

350z import will not start! Help!


Recommended Posts

My 03 plate imported Z is not behaving itself.

 

For the last 3 months it has had a fault where I turn the ignition and it cuts out, no attempt to turn over. To get the car going I would get out, wiggle the battery terminals a bit so the electrics would come back on, and then (after a couple of attempts) it would start, and i’d be back out on the road.

 

The usual happened last week, and now the ruddy thing will turn over but not fire up. I’ve changed the battery and am sure the fuel pump is fine, perhaps the fuel is stopping at the injectors? Why might this be? Completely confused at present! 

 

Thanks from a relative newbie 

Link to post
Share on other sites

Make sure that the battery is in good shape.

Make sure that the battery terminals are all good.

Check that you have not blown the fuse in the battery fuse link whilst you were messing with the terminals.

Link to post
Share on other sites

Cheers Alex, appreciate your thoughts

 

The battery terminals seem to have seen better days and have clearly been fiddled with in the past. Perhaps I will replace them and tidy the whole thing up a bit to see if that is an easy fix. My mechanic thinks fuel is getting to the injectors but not past them, is there a fuse relating to that? My ECU has also been sent away for a test. We have tested both fuse boxes and cannot find one that is blown?! 

Link to post
Share on other sites
  • 2 weeks later...

Just an update - we are still scratching our heads. It will not start! Any ideas would be appreciated!!

 

We tidied up the battery terminals and tested all the fuses, none of which have blown. 

The problem appears to be that fuel is getting to the injectors but there is no pulse, where does the pulse come from? The ECU? Because that has also been sent away and tested with no problems reported (it’s an M31 ECU box as mine is an import). 

 

There is a toad alarm/immobiliser on the car I know little about, but seems to all be working as it did previously. 

 

The car car will turn over, but not start. Mega frustrating! 

Link to post
Share on other sites

Check your CPS (crank position sensor)

 

However to be perfectly honest it could be numerous things causing this issue.

 

Might be a plan to get someone who knows there way around a 350Z to have a look.

 

Can you post up a picture of the fuseable link showing all the fuses.

 

Where are you based?

Link to post
Share on other sites

Hi Alex, thanks for your reply

 

I’m in Bognor Regis on the south coast. We phoned the actual Nissan dealership in the town and they said they would then send it to London. Any knowledge of those guys? Recommend any alternatives? Thought this forum might be a better place to look!

Link to post
Share on other sites
36 minutes ago, Forrest said:

I’ll go see if I can get a picture of the fuse link....

And remember and check your CPS.

 

The general rule of thumb is to avoid Nissan dealerships.

 

Also. most Nissan dealerships body swerve JDM imports.

 

There is a guy about an hour along the coast from you who may be prepared to help, however you would have to get the car to him and I am not sure if this is an option due to the distancing rules that are in place at the minute.

Link to post
Share on other sites

Cheers. Learning all the time. Will give the dealership a miss.

 

Will have to wait for the Mrs to get home before I send the pics as my old bastard iPhone will not focus on what it needs to XD 

 

This chap an hour up the road, does he operate as a mechanic or garage? I believe they are still allowed to operate? 

Link to post
Share on other sites
2 minutes ago, Forrest said:

 

 

This chap an hour up the road, does he operate as a mechanic or garage? I believe they are still allowed to operate? 

I have contacted him on your behalf and he will be in touch if he can help.

Link to post
Share on other sites

Hi,

 

@ZMANALEX is reffering to me as the guy up the coast, so you owe him a beer for taking the time to PM me - you'll have to post it as he is in Scotland :lol: 

 

 In different times I'd come take a look at the car with you but I had almost the exact same issue with a Zed a few years back, the fault turned out to be a poor engine earth if yoy take off the front black plastic top engine covert on the left hand side you will see a 10mm bolt holding down an earth lug, that is the earth pont for the injectors and the coil packs, if that has corrosion under it (an it will) the car will turn over throw no fault codes and not start - we tested it on a working Zed if you disconnect it the Zed won't start but will turn over until the battery dies.

So whip it off and give it a clean, you can also try putting a jump lead from the engine block ddirect to the battery negative to make sure you have a good engine earth, but that may not be required.

Yes it could be that simple mine was but took ages to find!

Good luck, I'm in Bournemouth and happy to help if I can :thumbs:

  • Like 1
Link to post
Share on other sites
1 hour ago, ATTAK Z said:

@Keyser prefers doughnuts !!!

Nope on a diet - lost 1.5 Stone since January :)

 

 

 

 

 

 

 

 

 

 

OK Send the doughnuts anyway :lol:

  • Haha 1
Link to post
Share on other sites
5 minutes ago, Forrest said:

Not sure, where do I find it? 

I will take that as a no then.

It is within the fuseable link.

It is the only fuse on its own.

The other fuses within the link are all in a row as per your image.

Link to post
Share on other sites

I would go back and check all the fuses in the other fuse boxes with a multi meter before you start looking elsewhere.

 

I would also check the specific relays.

 

There are a few common fuses in there, so pay particular attention to those.

 

How did you get on with the CPS?

Link to post
Share on other sites

Cheers Alex

 

 CPS is going to be inspected Monday and we’ll go through all the fuses again.

 

It is frustrating as the car had been a superb daily driver for over a year, relatively trouble free. Now it’s moving into something “taking up space” on the driveway territory :bang:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...