Jump to content

Sam_Patmore

Members
  • Content Count

    64
  • Joined

  • Last visited

Community Reputation

22 Excellent

About Sam_Patmore

  • Rank
    Z Hopeful
  • Birthday 03/09/1991

Location

  • Location
    United Kingdom

Recent Profile Visitors

245 profile views
  1. I know this is a REALLY old thread, but just wanted to say cheers to Andy for posting about it. I just had the exact problem so ended up stripping out my ipdm and there was corresion on the connectors. Cleaned them all up, plugged back in and she's back working
  2. Happy to take this over and book a club stand if we get the minimum 10. Not done it before but will give it a go!
  3. Sam_Patmore

    Spare Keys

    Hi, did any of these work?
  4. Hi All, I have a pair of Carbon Fibre Hydro-dipped 350z Window Switch Finishers. Both in Excellent condition and have no cracks on them. The passenger side one has some marks on it as seen in the photo. However, you can barely see these once they are installed on the car. Looking for £120 ono. Located in Essex
  5. Hi all, I'm after a pair of HFC cats for a de 350z. Wondered if anyone had a second hand pair at all they want to get rid of. Cheers
  6. I'll be along for the next one once lockdown is over. Would be good to meet some other owners!
  7. Im the same, COVID permitting I can do Saturday or Sunday, potentiality both 1. MatthewThain - FA53 FZZ - 350Z - 24th-25th 2. Dan Wilks - GJ04 DYB - 350z - 24th 3. Sam Patmore - YK52 AJM - 350z - 24th/25th
  8. Would a dodgy throttle body cause rich running?
  9. No stored codes, and regards to and O2 sensor, that was one of my thoughts but yer, no eml. I'l give the air filter element a look, see whats its like, I have a Takeda short ram intake but never had a problem with that before and i've cleaned that all up
  10. So I've been racking my brains over this and I have no other ideas on what to do next. Long story short, my Z had been laid up for a while and I decided to put her back on the road, sailed through the MOT all fine no issues etc. About a week later, she developed a misfire, so I replaced all the sparks and ignition packs, the car began running rich, loss of MPG. A couple of days later, I went over a horrible sleeping police man which destroyed my OEM Cats. had to drive home with the wrecked ones still on and, according to the mechanic, it was just a molten mess in them where it wasn't releasing any fumes. So I put my old decat pipes on. Still running rich, massive drop on the MPG, but no misfiring but has a rough idle, occasionally pops when I put my foot down. Since then I have done the following: Replaced the valve rockers as gaskets leaking Installed plenum spacer Cleaned all the throttle body Clean all the plenum chamber Cleaned the air intake Replaced the MAF sensor Done the pedal dance for ecu reset, throttle idle position etc And still the bloody thing is running rich and I have no clue why. The car isn't displaying any eml lights or anything but I just can't work out whats with the rich fuel mix and drop in MPG and when I say a drop, I'm getting roughly 14mpg. I will, once everything is over with this pandemic be getting it tuned and putting high flow cats on which should help but other then that I can't think of what else it could bethat it is still causing it. Would appreciate any suggestions
  11. He's gonna love me the amount I've had off him the past week
  12. Anyone know where I could possibly get a new weatherseal for the drivers side a pillar? Was replacing the a pillar and noticed that the think rubber seal you remove before accessing the a pillar screws is starting to perish. Cheers in advance

350z-uk.com

370z-uk.com

350z-uk.com

370z-uk.com

×
×
  • Create New...