Jump to content
Ozzy225

Vortech Supercharger cog belt issues

Recommended Posts

Hey Guys,

 

I have just installed a V2 supercharger on the Zed (from Paul's Hulkbuster build on here). Everything is great except i'm getting belt movement on the 32 tooth jackshaft pulley  and 28 tooth supercharger pulley. At idle the belt is ok, but on increased rpm it moves and protrudes to and over the pulley edge, even slightly fouling the charger itself, then moves back central when it falls back to idle. 

I'm running the 75 cog belt which i believe is correct for non-revup set up which i am. how ever the idler tensioner pulley is maxed out and there is still a lot of play in the belt. 

 

Anyone had this issue? 

 

Is it a case of buying and trying a new belt? there's so much slack i was tempted to even buy the revup 70 cog belt.

 

any help greatly appreciated.

 

Cheers

 

Oz

Share this post


Link to post
Share on other sites

If the belt is moving there may be an alignment issue,

However the play is not helping, any chance you could post a pic of the setup so I can see it? - I've done a few V2/V3 setups and have used different methods to keep tension correct and avoid belt slip.

Share this post


Link to post
Share on other sites
1 minute ago, Keyser said:

If the belt is moving there may be an alignment issue,

However the play is not helping, any chance you could post a pic of the setup so I can see it? - I've done a few V2/V3 setups and have used different methods to keep tension correct and avoid belt slip.

Thanks Keyser, Photo above and below 

 

20190501_203856_zpsicbw8htb.jpg

Share this post


Link to post
Share on other sites

:lol:

 

you got a pic up while I was asking for it :thumbs:

 

Problems I can see - That belt is to long defo drop 2 teeth maybe 4 (try it and see.

You need a washer between the spacer and the mounting plate for the tensioner pulley to stop it dragging towards the front.

That should sort it.

 

On a side note and it may just be me but either that belt is narrow or the tensioner pulley is wider than I remember.

No chance you got the pulleys muddled up is there? The one that the V bely runs over with the non grooved side and the one that is currently the toothed belt tensioner?

That's just an "are you sure" type observation not a statement of fact not saying its wrong just trying to help :)

 

Do remember that I have been running a GTM supercharger for the last 3 years which is completely different!

 

 

Share this post


Link to post
Share on other sites

Thanks for that Keyser, was struggling to find any answers with my google searches.

 

Ill get a washer fitted first thing tomorrow and order the 70 cog belt from Torqen and see how that goes. 

 

You confused me with the different tensioner pulleys there. The pulleys were still installed as to when Paul was running it all on his Zed, So i'm presuming there in the correct positions :lol:

Share this post


Link to post
Share on other sites

Try the shorter belt, and see how it goes, if the pulleys were like that it is most likely correct so don't start changing anything just yet.

 

Let us know how it goes :thumbs:

Share this post


Link to post
Share on other sites

what mine looks like (excuse the marked pulley as I had an incident where my pipe blew off and made a mess.

59761295_10161812263840441_8801473151646

Share this post


Link to post
Share on other sites

Can I play the “show us your charger” game too?

 

Here is mine.. belt sits exactly in the middle of the big cog and is perfectly at the end of the s/c cog. V3SCi not V2 however. Spacers as shown but no washers. Belt is original supplied with the Vortech kit. The (lightly tensioned) tensioner has a small bit of tolerance between the pulley flanges and the sides of the belt. 

 

Taken in my garage so flash lighting is a bit weird.

 

BF8C5C82-3135-41F0-9555-2D65B18E7597.jpeg.18394a4b6f57df4223f5d5978a9bc204.jpegE36899C1-6CE0-4B72-BCBD-A5097520548E.jpeg.da9c89d14f3063b96d3f67821703e153.jpeg

:thumbs:

 

Share this post


Link to post
Share on other sites

Cheers for the reply's guys, adding the additional washer solved all my issues so thanks again @Keyser :thumbs:.

 

I did order a 70 tooth belt, that turned out to be far to small, who knew 5 teeth would make such a difference. 

 

I still may and try and get a smaller belt made up as I still max out the idler pulley, but now there's zero movement and its not fouling anything I may just see how it gets on.

 

Cheers again :) 

  • Like 2

Share this post


Link to post
Share on other sites

Glad you got it sorted. Sorry i forgot to take a pic, desperate to get to bed after night shift and totally forgot :blush:

Share this post


Link to post
Share on other sites

By the way guys I can recommend a carbon toothed belt available from gates - you should definitely buy if you can get hold of it.  I had a normal rubber toothed belt which snapped, this one just won't lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

350z-uk.com

370z-uk.com

×
×
  • Create New...