Jump to content
Ortega_9

350z gtm Twinturbo kit

Recommended Posts

1 hour ago, Ortega_9 said:

Put this Utec on Yesterday, and only just had time to fire it up.

 

it has a map from a Sc setup, but is scalled for the Injectors, but idles REALLY bad, so shut it right off.

 

ill throw the computer at it and put a Gtm tt basemap in and see how it goes.

 

otherwise i'm serious considering the haltech ecu....

IMG_5058.JPG

there is an issue with some maps for the utec ,because when they changed the firmware they removed the setting for the injector size so if you have a map written for the early firmware and they used this setting

it is ignored by later firmware and your fuelling will be out you can pretty much assume that any non oem injectors will be bigger so this will result in a rich mixture in this case

if you change the ECU consider the link G4+ plugin ecu I went from a UTEC to this and I love it totally differant league 

:)

Share this post


Link to post
Share on other sites
17 minutes ago, andybp said:

there is an issue with some maps for the utec ,because when they changed the firmware they removed the setting for the injector size so if you have a map written for the early firmware and they used this setting

it is ignored by later firmware and your fuelling will be out you can pretty much assume that any non oem injectors will be bigger so this will result in a rich mixture in this case

if you change the ECU consider the link G4+ plugin ecu I went from a UTEC to this and I love it totally differant league 

:)

Thanks for the input.

 

i have had the laptop on this Utec and i Can see Injectors size and Stock Injectors size under constants. 

As i got the damn thing laying around Anyways, I will have a go at it, Otherwise i will move on.

Share this post


Link to post
Share on other sites
5 hours ago, Ortega_9 said:

Thanks for the input.

 

i have had the laptop on this Utec and i Can see Injectors size and Stock Injectors size under constants. 

As i got the damn thing laying around Anyways, I will have a go at it, Otherwise i will move on.

if you can see the injector size under constants you must have the old firmware but just beware you may also come across the opposite problem of running an new map on old firmware but in that case the mixture will be lean :wacko:

:)

Share this post


Link to post
Share on other sites

That Would be even worse...

 

i'll have an eye on the AFR and give it a go tomorrow.... i'm not driving it, it's still on Jack stands.... i have a drip, and i can't find the leak... Well the car does..

Share this post


Link to post
Share on other sites

So dicking around in the ecu. Uploaded the ApS TT basemap and will try to run that to start on. 

But not sure where i Saw the Injector size scaling in the constants. Anyone knows if this version is the "new" or old?

IMG_5065.JPG

Share this post


Link to post
Share on other sites
15 minutes ago, Ortega_9 said:

So dicking around in the ecu. Uploaded the ApS TT basemap and will try to run that to start on. 

But not sure where i Saw the Injector size scaling in the constants. Anyone knows if this version is the "new" or old?

IMG_5065.JPG

pretty sure 2.8 was the last and latest version so you can't set the injector size also bearing in mind I haven't played with one of these for a while I think you have to either alter the 0% load column which will adjust the factory ecu fuelling or set the open loop thresholds so that it doesn't revert back to the factory ecu other wise the factory ecu will be running your larger injectors with it's standard timing

:)

  • Thanks 1

Share this post


Link to post
Share on other sites

I Think theese parameters are from the Sc map.

i only loaded the timing, fuel and boost map. No parameters. Will change all tomorrow.

 

and thats funny. I'm still sure i Saw it in there somewhere :wacko:

Share this post


Link to post
Share on other sites
10 hours ago, Ortega_9 said:

I Think theese parameters are from the Sc map.

i only loaded the timing, fuel and boost map. No parameters. Will change all tomorrow.

 

and thats funny. I'm still sure i Saw it in there somewhere :wacko:

maybe you saw it in the documentation they never updated it when they changed the firmware also you need the correct parameters map to go with the rest

:)

Share this post


Link to post
Share on other sites
3 hours ago, andybp said:

maybe you saw it in the documentation they never updated it when they changed the firmware also you need the correct parameters map to go with the rest

:)

I just had another look, i Can see that the injector scaling is missing.... must have been in the documentation then:blush:

 

i have the parameter map for the tt basemap aswell. But when i try to upload, it says it corrupt. When i view it in notepad it looks like fuel or boost map, is that wrong? I though it was suppose to be parameters for the parameter block beneeth the 5 map sections

Share this post


Link to post
Share on other sites
5 hours ago, Ortega_9 said:

I just had another look, i Can see that the injector scaling is missing.... must have been in the documentation then:blush:

 

i have the parameter map for the tt basemap aswell. But when i try to upload, it says it corrupt. When i view it in notepad it looks like fuel or boost map, is that wrong? I though it was suppose to be parameters for the parameter block beneeth the 5 map sections

did you upload the parameters file to the parameters tab or to the aps tt map ? there is only one set of parameters on the utec and it is applied to all maps on the ecu

:)

Share this post


Link to post
Share on other sites
1 hour ago, andybp said:

did you upload the parameters file to the parameters tab or to the aps tt map ? there is only one set of parameters on the utec and it is applied to all maps on the ecu

:)

I actually have no idea where i tried uploading it, but I'll bet you I tried uploading it as i did the map file. I Think I'll have to give it another go tomorrow.

Share this post


Link to post
Share on other sites

And done with the Utec....

just ordered a stand alone ecu with all sensors etc. 

 

Share this post


Link to post
Share on other sites
On 02/05/2018 at 15:29, Ortega_9 said:

And done with the Utec....

just ordered a stand alone ecu with all sensors etc. 

 

Which one did you opt for?

Great build btw :)

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, wizard said:

Which one did you opt for?

Great build btw :)

I went with a full AEM infinity setup.

and Thanks.

 

not much going on at the moment. Waiting for parts and trying to wrap the front bumper around all the pipework that's gone on...

Share this post


Link to post
Share on other sites

Almost Got the inner arches and front bumper wrapped back on....

 

ALL that pipework, intercooler, air filter etc. That goes underneth and need to fit 100% to have the arches and bumper put back on is mind twisting....

 

But getting there..

 

I want to be done in time to start putting ecu, harness, sensors etc. on, as soon as it shows up, hopefully friday.

IMG_5105.JPG

IMG_5106.JPG

IMG_5107.JPG

Share this post


Link to post
Share on other sites

Just started putting on the harness and making the wireing that needs to go between the aux conector and the sensors.

also making up a few parts, fuel press t-piece etc.

 

all wireing is beeing done with crimped ends and run in protective "socks" and with automotive connectors

IMG_5148.JPG

IMG_5149.JPG

IMG_5150.JPG

image.jpg

Edited by Ortega_9

Share this post


Link to post
Share on other sites

And all the wireing is done...

now i need to run everything where it needs to go, and then mate it with the aux harness on the infinity.

I'll have a read up on the oem sensors. I Think i Can loose a few of them with the aem sensors installed

IMG_5151.JPG

Share this post


Link to post
Share on other sites

The nuts and bolts look tricky enough to do, but the wiring is a dark art. Great effort doing all this yourself mate. Great build.

  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, SuperStu said:

The nuts and bolts look tricky enough to do, but the wiring is a dark art. Great effort doing all this yourself mate. Great build.

Thanks.

Taking alot of pride in doing it myself.

and having build quite a few cars over the years, I always try to step up my game.

 

 

 

Share this post


Link to post
Share on other sites

Just pulled the top of the plenum as i wanted to fit a bigger port for the map sensor aswell as for the bov vacum.

and also fitted the air temp sensor in the intake pipe of the plenum.

and last i blocked the water Lines running to and from the throttle body, as i'm never gonna run the car in the winter, and i have a fealing it's gonna get hot enough without having the warm coolant running through.

IMG_5152.JPG

IMG_5153.JPG

IMG_5154.JPG

IMG_5156.JPG

Share this post


Link to post
Share on other sites

And back together, now with fuel press sensor, map sensor, air temp and the bigger vacum ports.

 

now i need to do the Oil press and temp sensors, aswell as the wideband o2 sensors for the infinity... 

IMG_5158.JPG

Share this post


Link to post
Share on other sites

is that swarf around the air temp sensor you don't want that getting in the engine

:)

Edited by andybp

Share this post


Link to post
Share on other sites
7 hours ago, andybp said:

is that swarf around the air temp sensor you don't want that getting in the engine

:)

It's a piece of ptfe tape, it was pulled of before putting it back together.

:thumbs:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×