Jump to content

350z import will not start! Help!


Recommended Posts

Ok, update....

 

The CPS is alright after testing, the earths have been cleaned and we are still having the same problem. 

 

We are thinking the next step is to send the ECU to a company called ECU EXPRESS in Stoke, who will fix the relevant part of the ECU that is not sending a pulse to the injectors. They will fix it and return it back to me for the sum of £400. 

 

We are thinking that all the the "fiddling" with the battery will have caused a spike that will have damaged that particular part of the ECU. If this is sounding completely wrong to anyone, or if anyone can think of anything I can do before shelling out £400 whilst on Furlough, I would be very grateful! 

Link to post
Share on other sites
  • 10 months later...
  • 1 month later...

Hi guys,

 

Apologies, yes I did. £80 ECU off eBay, plug and play. Big thanks to Mark at Abbey motorsport who was very helpful. Turns out if you know the specific part number (important) of the ECU they can be found quite readily for sale on the web. Mark supplied me with that and there were a few available online. 

 

I had probably fried the previous ECU by tampering with the battery too much. 

 

A lesson learned to get to the bottom of smaller problems before you create bigger ones! 

 

Thanks 

Adam 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...