Jump to content
AlwaysMoody95

Cold Start Squeaking from Engine bay

Recommended Posts

Hello,

 

Recently my 350z has started squeaking/Squealing in the mornings, sounds like it's the belt, but seen a few people say it could be bearing,

 

Just wondering if anyone had any thoughts and whether or not it might be best to replace the belt itself as it looks a little fraid.

 

Noise goes once the engine/car is warm though

Share this post


Link to post
Share on other sites

Fit new belts and adjust to manufacturer's spec.

 

Check all the pulleys when you have the belts off.

 

New uprated belts are in stock and good to go same/next day.

 

Just drop me a PM if I can help further:  @ZMANALEX

 

 

Share this post


Link to post
Share on other sites

PM received and replied to:

 

Your car is an HR which only has one belt which is self tensioning.

 

 

Share this post


Link to post
Share on other sites

Can spray wd40 on the belts which should make them stop squealing if they're causing the noise. May be worth changing them anyways!

Can check their tightness or condition which doesnt take 5 mins too :)

Share this post


Link to post
Share on other sites

Or try spraying with rocol belt dressing which makes the belts sticky 

Share this post


Link to post
Share on other sites
39 minutes ago, AlwaysMoody95 said:

I have, just waiting for a reply 

I replied by PM on Monday in answer to your PM with a price delivered.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

350z-uk.com

370z-uk.com

350z-uk.com

370z-uk.com

×
×
  • Create New...