Jump to content

Please Help: 350Z HR Very High Idle after Changing Gallery Gaskets

Recommended Posts



This is my first post, though I have been lurking for years.


I have a 2007 350Z HR (78K km), euro, package (brembo, etc.).


I have just done the oil gallery gaskets (and changed a lot of things along the way, see below), and am experiencing very high, fluctuating idle whenever I start the car. The car starts at 3000 rpm and fluctuates between 2200 and 3000 rpm. Oil pressure stays at close to max (for the few seconds that I let the engine run like that). I have tried three times now and it's the same every time.


The car has UpRev tune done at Horsham in 2019.


Here's two videos of the issue 






Note: the whining sound in the middle is from when I release the clutch pedal. I've had this for years, and I believe it's a bearing in the gearbox that needs replacing. Also, at some point I slightly reved the engine and then I let it idle.


After I put it together (see below for what's been done) and saw the issue, I tried the following:

  1. Cleaned the MAF sensors with MAF sensor cleaner.
  2. Lifted the intake box and checked underneath and inside.
  3. Performed the "Accelerator Pedal" and "Throttle Valve Closed" procedures from here.
  4. I don't have a good OBD scanner, but I do have the UpRev cable and checked codes with it. It only shows an error code related to the steering angle (after googling, turns out it's actually about the cruise control. I have an aftermarket steering wheel and thus have removed the cruise control switches). No other error codes.
    No CEL or such.


I tried three times (while also bleeding the coolant and topping up oil), and am afraid to let the car run for more than a few seconds. Thus, I haven't performed the "Idle Air Volume" procedure, which requires the engine to be warm.


What I have done along the gallery gaskets replacement:

  1. Cleaned the throttle bodies. Removed them while battery was disconnected. I did move the valves while cleaning. I am mentioning this because I have read of people having had issues with this.
  2. Installed a GReddy oil pan.
  3. Installed a ConceptZ (Setrab core, 34 rows) oil cooler.
    1. I followed ConceptZ's guide and oriented the sandwich plate so that the lines are at the 11 o'clock position.
  4. Removed the stock oil cooler (replaced the long stud with a Nissan short one, 15213-31U00, as the oil pan wouldn't fit otherwise. Bypassed the stock oil cooler by connecting the two pipes with each other.
  5. Replaced all rubber hoses with silicone ones.
  6. I didn't replace the chain, tensioner, or the guides. Should have done it, but forgot about it and needed to put the car together. Chains, guide and tensioner were in good condition.
  7. Replaced valve covers since they were leaking at the spark plug o-rings.
  8. Replaced spark plugs.
  9. New water pump and thermostat.
  10. Oil capacity is worth mentioning, as I find this a bit surprising perhaps. So far I have put in 8.5 liters and the level is at half between MIN and MAX. I filled the oil cooler and the filter before installing them and that was about 1 liter. Then there's GReddy oil pan. But the FSM says 5.5 liters on a dry engine. Which means that the oil cooler and the larger pan have accounted for another 3 liters. Seems a bit high to me.
  11. The car has sat in the garage for 10 months (battery has just been recharged).


I took off the intakes and recorded the movement of the throttle valves when ignition is turned on.




Please help, any clues?


My concerns are:

  1. Did I mess up the timing?
  2. Is the ECU fried?
  3. Throttle bodies broken?
  4. Oil--worth mentioning that I am surprised by the amount of oil the car has taken.





Edited by VoodooBoot
Link to post
Share on other sites

Tough one this, my first thoughts were moving the throttle with the battery connected and vacuum leak, but you've already covered those. Hopefully someone more technical will be along shortly. Good luck. You could try giving H-dev a bell.

Link to post
Share on other sites
1 hour ago, Stutopia said:

Tough one this, my first thoughts were moving the throttle with the battery connected and vacuum leak, but you've already covered those. Hopefully someone more technical will be along shortly. Good luck. You could try giving H-dev a bell.

Good suggestion, thanks, I am going to give them a call. 

Link to post
Share on other sites

I haven’t been able to reach Horsham today. In the mean time, I gave Mark at Abbey a call and he suggested the ECU might have been corrupted due to cleaning the TBs. Abbey would have to send the ECU to the US, while Jez at Horsham would do it on-site. Either way, I would lose the UpRev tune, and it might not even be possible to reflash the old map onto a new UpRev version.


I did more smoke tests, intake and valve covers—all good.


Finally, I thought, let’s let it run a bit longer than before (say a minute) and see what happens. Result is that the RPM drops to around 1000 (still too high) with occasional surges. 


So, now I can at least try the idle volume relearn since the car can be warmed up. Either the relearn works or the ECU is shot and has to be reflashed.


When I filled up the car with oil, I hadn’t realized that the front was lifted (the car has sat like that for a long time). So, apparently I’ve overfilled it and would need to drain a bit. Yeah, I am that stupid 🥴





Link to post
Share on other sites

Timing as everyone says is critical to getting it right, you know you have when the light starts to flash. I used this document & it went perfectly: https://uprev.com/documentation/Resets-for-Nissan-Infiniti-Functions.pdf


I used this video too: https://www.youtube.com/watch?v=TZJfWQLGUZI

  • Like 1
Link to post
Share on other sites

I've been trying the relearn for the past two days. I believe I am getting the timing right, but if someone could please confirm?

The CEL starts blinking after 10 sec (it's the 24-25 sec. mark on my stopwatch since starting the procedure), then I release the gas pedal within 3 sec. of the CEL staying on, and after 3 sec. have passed, start the car. I can see the the ECU trying to adjust. After 20 sec. I rev it up.


I have tried:

  1. Pulling up to 3 injectors—throws a CEL (misfire), which screws up the relearn.
  2. Pulling up to 3 spark plugs—throws a CEL.
  3. Disconnecting the TBs with the battery connected, disconnecting the battery, disconnecting the ECU.
  4. Disconnecting the battery and draining.

What I have been having some success with is turning the steering wheel all the way and turning on the AC, thus lowering the RPM a bit. At some point today, I got it down to about 1000 RPM, but after a restart, it's still no good.


I drove it 20-ish km today and it seems a bit better.


Jez gave me a call back and said he could reflash the ECU and also keep my UpRev tunes. I would lose the immobilizer but that's OK.


I am planning a long trip with the car and need to sort this out as soon as possible. So I will try driving it a bit more and a few more relearns, and if that doesn't work, will mail the ECU to Jez.


Link to post
Share on other sites

I am happy to report that the car has almost returned back to normal idle speed.


For the past week, I have been driving as much as I can, executing the idle relearn multiple times per day, after a drive.


At some point, I got the NDIS III Lite Android app that I put on an old phone, and I used the app to perform the procedure (though I had already performed the pedal dance 50-100 times).

It seems to me that the app is better than the pedal dance for performing the procedure. The reason is that the app runs the relearn while the engine is already running. As often reported by people experiencing the high idle/idle surge, the idle is very high when the engine is started and goes down after some time. With the engine running, my idle was initially around 1200 rpm and went down to 800-900 rpm after a few days. With the app, the idle relearn could be performed at a much lower initial idle, which I think makes a difference. Note that multiple people reported that the idle relearn procedure expects the idle to be max. 850 rpm.


In the mean time, I also got a new, slightly larger battery (replaced a Bosch 64 Ah with a Bosch 70 Ah, which fits just right). Not sure if this makes a difference, the old battery was 4 years old, was holding voltage, but capacity was measured to be around 60%. Alternator was diagnosed to be working correctly.


The idle is still not perfect. On a cold start, the car ocassionally does one or two surges (around 2500–3000 rpm) before starting to steadily go down. On a warm engine, there's a very, very slight unsmoothness in the idle. I hope this is going to smoothen out with time.


Thanks, all, for the support. I will report further on how the idle is behaving.


Edited by VoodooBoot
  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...