Jump to content

Recommended Posts

Hi all took my z out this evening and the clutch didnt retract fully after each gear. The gear change was ok but the pedal didnt fully come back up. Then when I got home there was rattling noise which went away when the I pressed the clutch back in but came back after releasing. Also moving the gear stick seemed to rattle also. Is this sounding like big expensive work?

Link to post
Share on other sites

Do you mean the pedal didn’t retract fully? and what age is your z? Clutch slaves are notorious on earlier models so an upgrade kit is recommended from tarmac, You could always start there and work forwards, tbh having your clutch replaced shouldn’t be that expensive the parts are more of the burden than the labour as the booktime is about 3.80 or so auto data says( depends if you need the dual mass replacing) when you turn it off or start it up do you hear a prominent knocking? When I lift my foot off the clutch I can hear the rotational movement from the box 

Link to post
Share on other sites
10 hours ago, Steven said:

Hi all took my z out this evening and the clutch didnt retract fully after each gear. The gear change was ok but the pedal didnt fully come back up. Then when I got home there was rattling noise which went away when the I pressed the clutch back in but came back after releasing. Also moving the gear stick seemed to rattle also. Is this sounding like big expensive work?

morning,i had the same thing on my 06 plate 350z,i replaced the slave cylinder,new braided line and dot 5.1 clutch fluid and its sorted,i also made up a heat shield for the clutch line as it runs fairly close to the cat/test pipes,as i found after a hard drive in higher ambient temps ,the clutch pedal felt sloppy.

Link to post
Share on other sites

Sounds like the clutch slave cylinder to me too. Same thing happened on my 350Z (DE) when i had it. The pedal would get stuck about halfway coming back up but with a flick of the toe would come right back up. Mine was worse when hot.

 

I bought a Stoptech slave cylinder from Tarmac Sportz, had it fitted and the system bled and all was good again.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...