Jump to content

Front end 'creak'..


Recommended Posts

I have a troublesome issue with my 370 that I just can't find.. neither can my dealer nor my local (awesome) MOT tester..

 

I appreciate its always difficult to diagnose a noise on the interweb!! :wacko:

 

Any advice, checklist gratefully received, so..

 

2017 car, spun and damaged by previous owner when only a month old.. now with nearly 3,000 miles on it (yes, really). Damage limited to front bumper, OSF wing and OSF wheel. 

 

Horrendous 'creak' when pulling away forwards or backwards under power, only with steering input. The noise definitely comes from the kerbed (OSF) corner somewhere.

 

Car was aligned a couple of weeks ago with report below. Wheels are straight and true. Car drives 100% and only makes the noise at 'parking/manoeuvering' speeds.

 

Checked all bushes, bearings, shock, upper and lower arms, rack etc. and all okay.

 

As a final resort, and as the noise seemed to come from hub area, I changed hub/bearing too but that's made no difference.

 

Ideas??

 

 

DSC07395.jpg

Edited by ibrakeformoose
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...