Jump to content
Catchy66

Jolt/ kanjaroo on idle and while driving HR

Recommended Posts

Right so new member here, had my 2008 HR with 110K on the clock for about a year now (had 89 when I got it) absolutely loved it, but it’s got an issue I’m struggling to solve. It’s a jolt between 1100-2000 revs, it happens when selecting cruise control at 30mph in 5th gear, it feels like just as it’s selected the fuelling it suddenly forgets it jolts quite violently and then Is fine. It also does it under light throttle but is much worse if going up a hill (I’m guessing because of more load), it also does if you’re sat at idle, give it a rev and just as the revs get to 1500rpm it hesitates and jolts slightly. 
 

It’s recently done it slightly while just idling and that’s what’s made me turn to the forum. I’m thinking it’s AFR related, but doesn’t throw any codes. Throttle bodies are a bit dirty but appear to be functioning fine and tbh I don’t dare clean them as I’ve heard horror stories. I’ve replaced both fuel dampeners on the rails but doesn’t seem to have made a massive improvement. 
 

any help would be greatly appreciated, as I’m unwilling to just slap sensors and parts on it left right and centre. If anyone has experienced this or knows any way that can help diagnose the issue it would be greatly appreciated

 

thanks!

Share this post


Link to post
Share on other sites

I could be wrong but pretty sure you cannot select cruise at 30mph or below (for obvious safety reasons you wouldnt want to be on cruise when in town centres etc) - does it happen at higher speeds. Again, could be wrong but 5th gear at 30mph sounds too high a gear and labouring the engine, from memory?

Share this post


Link to post
Share on other sites

Definitely can select cruise at 30mph, but it does it at 40 as well and lower, speeds seem to be irrelevant It’s more about the Rev range, and it’s not an issue I’ve had for the entire ownership until recently! Sucks though :( 

Share this post


Link to post
Share on other sites

I'm sure this is a (fairly) common issue with HR's, from what I've read on other similar topics an Uprev remap seemed to fix the issue. Might be worth firing a PM to one of the tuners on here like @Jez @ H-Dev

Share this post


Link to post
Share on other sites

I’ve definitely heard of a tune fixing it and it is a route I’m seriously considering. However because it’s not an issue that’s I’ve had since ownership, I’m lead to believe that something has changed e.g sensor partial failure, throttle flap sticking, spark plug gap too wide etc, I could be completely wrong about that, I work in a dealership and we do get 10+ year old cars that come in for an ECU update to fix issues that have suddenly started occurring. I think I’ll have a look at getting it tuned still since it’s more than likely my best shot at getting it fixed, the best way I can describe the jolt is it feels exactly the same as if you kick the clutch. It’s properly violent 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

350z-uk.com

370z-uk.com

350z-uk.com

370z-uk.com

×
×
  • Create New...