Jump to content
michaelgordon

HR Earthing kit

Recommended Posts

I looked round and on the american site for a guide to put an earthing kit into my Hr and while there were a few for DE they were not suitable so i decided to just do it.  I used the Stillen install instructions as a base line but as they are american, the battery is on the wrong side so guessed really.  Not completely sure I've done it right but car starts so i don't think I've messed any thing up.  If anyone has any suggestions or can point out where i may have gone wrong please comment and let me know.

 

I did clean the paint from any parts of the chassis that made contact.  Cant say ive noticed a different on the volt meter either at ignition or with engine running.  Not driven it yet so cant comment on idle, smoothness or increased electrical efficiency, to bright for headlights yet which has been reported as improving from other threads and topics i read.  

 

First pic, overall finished showing most the connection.

1_(2).jpg.f2e9ecb7642917cef3c37ad1b1cf1299.jpg

 

 

First - There is a threaded hole just behind the washer fluid cap. This was a bit of a pain due to location but it eventually went in.  From here this cable routes to the engine block.

2.jpg.18278a780dfefcffac6ce14349e2e7f9.jpg

 

Second - The first cable from threaded hole into engine block & a second cable from engine block to lower earth point on block.

3.jpg.5da29b871c9c7b085a31ca53860c52b9.jpg

 

Third - You can see the cable going to the lower earthing point from the block above.  The third cable goes from the upper earthing point, not the top one but the one in the middle of this pic to the bottom threaded hole next to the intake.

4.jpg.c47b3a96f3a6b91408b81b10b29a36bc.jpg

 

Fourth - The cable in the bottom threaded hole from the middle earthing point from previous picture.  Also from the previous pic the Top earth point cable goes to a bolt under the air con tap, this can be seen better in the next pic.

6.jpg.4b775de9337a64f8c62b29cdd0831018.jpg

 

Fifth - Pic showing cable from top earth point to bolt by air con cap.  There is then a cable from this to the top threaded hole in previous pic.

5.jpg.3b640b221b777520d7df6a044b8e7749.jpg

 

Sixth - I put two extra from the current battery earth point to battery, there is also a cable running from the chassis connector to the top threaded hole in pic 5, this ran under the wiring loom foam block.7.jpg.96d3f46d20b30f5b26825cc9ab2dd92a.jpg

Share this post


Link to post
Share on other sites

Have you noticed any gains or better throttle response after doing this? Been considering doing this with mine as from time to time I feel a acceleration stutter. 

Share this post


Link to post
Share on other sites

There is I believe some data in Horsham developments website about this...I got one years ago and must noticed nothing (many people call it snake oil) but it does look cool if you get a nice colour!

 

if you have acceleration stutter would recommend posting up details for forum members to comment on :thumbs:

Share this post


Link to post
Share on other sites
10 minutes ago, coldel said:

There is I believe some data in Horsham developments website about this...I got one years ago and must noticed nothing (many people call it snake oil) but it does look cool if you get a nice colour!

 

if you have acceleration stutter would recommend posting up details for forum members to comment on :thumbs:

Yeah I might have too. Although I read on the american forums that the stutter could be a grounding issue. Will try that first then come to the forums after if no good.

Share this post


Link to post
Share on other sites

Check and clean all your current grounds

Share this post


Link to post
Share on other sites
1 hour ago, coldel said:

Check nd clean all your

Had them on my 350z DE 6 years ago. Looked nice but didn't make any difference. More bling than zing.

large.gallery_17208_353_137937.jpg.ef07ffb5160547ff5689fb1395f5ae11.jpg

Share this post


Link to post
Share on other sites

Nothing too noticeable really.  I did this quite soon after getting it so wasn't really used the the feel.  

 

The way I looked at it was that it can't really do any harm.

 

I only did it as in my last car there really was an improvement everything just felt smoother.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

350z-uk.com

370z-uk.com

350z-uk.com

370z-uk.com

×
×
  • Create New...