Jump to content
Dave_S

Clutch wont disengage

Recommended Posts

First off haven't posted in awhile. My Z has transformed from a road car to a track only car (only in the early stages of track slag build!!) , which leads me to the clutch issue! 

 

Installed a new tarmac sports lightened flywheel and RTS stage 1 clutch while the car was still on the road. Although bite point was very low only 1-2" off the floor!! Couldn't get my head around that, tried pedal adjustment, thats best i could get.

Did 1000-ish kilometers on clutch no issues, car then taken off the road for track only.

1st track day and during the 5th 15min session the car just suddenly wouldn't go into any gear while running. Goes into all gears when off. Was like the clutch wouldn't disengage. Had to start car in gear to drive it back on to the trailer.

 

Suspected hyd issue but new slave, braided lines and motul rbf660 all installed not long before clutch. No air, fully bled.

 

Removed gear box today to find the clutch disc had cracked / torn in 2 places and seperated along the outer edge between each. Surprised at this as car only has breather and exhaust mods.

Oh its the 2006 rev-up!

 

Would this damage prevent it disengaging though? Or is there another issue here too? Maybe master cylinder gone too?

 

Oh damage is on the pressure plate side not flywheel side.

 

Any help at all would be great

 

Dave

 

IMG-20181108-WA0005.jpeg

IMG-20181108-WA0008.jpeg

IMG-20181108-WA0011.jpeg

Edited by Dave_S

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×