Jump to content
Adrian@TORQEN

*** TORQEN *** 350z Nismo 380RS Acceleration pedal

Recommended Posts

Hi David,

 

Many thanks for your order. 30-45seconds o swap it :) 

 

Will leave tomorrow and should be with you next day.

 

Kind regards,

Adrian @ TORQEN 

Share this post


Link to post
Share on other sites
40 minutes ago, Adrian@TORQEN said:

Hi David,

 

Many thanks for your order. 30-45seconds o swap it :) 

 

Will leave tomorrow and should be with you next day.

 

Kind regards,

Adrian @ TORQEN 

Fantastic, thank you!

Share this post


Link to post
Share on other sites

 

On 22/10/2018 at 18:30, Adrian@TORQEN said:

Hi David,

 

Many thanks for your order. 30-45seconds o swap it :) 

 

Will leave tomorrow and should be with you next day.

 

Kind regards,

Adrian @ TORQEN 

Hi,

 

Mines not gone that well.

The plastic clip on the back of mine seems to be far larger than just a small one at the top.

I managed to pop off the one side of it but now its bent so won't clip back.  I still can't get it to come off the pedal though, so I can't change it...

Share this post


Link to post
Share on other sites
3 hours ago, daveo132 said:

 

Hi,

 

Mines not gone that well.

The plastic clip on the back of mine seems to be far larger than just a small one at the top.

I managed to pop off the one side of it but now its bent so won't clip back.  I still can't get it to come off the pedal though, so I can't change it...

What model of z do you have ?  Should always fit to be honest 

Share this post


Link to post
Share on other sites

GT 

Not sure what's gone, maybe the clip is the same but it's definitely bent now. Will have to replace it. 

Share this post


Link to post
Share on other sites

 

On 26/10/2018 at 18:41, daveo132 said:

 

Hi,

 

Mines not gone that well.

The plastic clip on the back of mine seems to be far larger than just a small one at the top.

I managed to pop off the one side of it but now its bent so won't clip back.  I still can't get it to come off the pedal though, so I can't change it...

 

On 26/10/2018 at 22:41, PPod said:

What model of z do you have ?  Should always fit to be honest 

 

Think I found the problem.  It's all one piece on the back.  07 GT spec.

DSC_0110.JPG

Share this post


Link to post
Share on other sites
15 hours ago, Adrian@TORQEN said:

Dave, can't see much from that photo, perhaps is worth taking a quick video.

See this video on the installation:

https://www.youtube.com/watch?v=cX-QyYX6-0k

is your model different?
 

Hi Adrian, 

Sorry, I didn't see this last night. 

Yeah, I think mine is one large piece of plastic on the back and not just the small clip. 

 

I'm actually down at Horsham Developments on the 23rd, so wouldn't be too much for me to pop to your place if that's any good? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×