Jump to content
zippypooz

Issue with vibration....HELP!

Recommended Posts

Hi guys, i currently have an issue at higher speeds, around 75mph plus where the car starts vibrating, including the steering wheel, gear stick and general ride.

I thought it may be a wheel balancing issue but that shouldnt affect the gear stick i dont think. Ive recently had new banana arms fitted and am wondering whether it could be that.

Any advice would be great, thanks in advance!

Share this post


Link to post
Share on other sites

Needs taking back to the garage that replaced the arms fella

  • Like 1

Share this post


Link to post
Share on other sites

Yup its going back on fri. Theyve already had to be tightened once since fitting.

Share this post


Link to post
Share on other sites

You say it shouldn’t be the wheel balancing, have you had it checked?

Share this post


Link to post
Share on other sites

The balancing was done recently but not ruled it out. It’s going in to the garage on Friday so we’ll see.

Share this post


Link to post
Share on other sites

I’m mistified as I’ve never seen you drive faster than 60mph in your z.

  • Like 1

Share this post


Link to post
Share on other sites

Very easy to lose a weight, but in the short term just check that all your wheels are tight and that there is no play on all 4 hubs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×