Jump to content
Nso93

Nathan's 370

68 posts in this topic

Recommended Posts

On 21/12/2017 at 21:40, nissanjuke said:

YES YOU GOT A GOOD DEAL THERE:D

Just a little heads the ultra racing brace isn’t a direct replacement as it’s not long enough. I’m picking up a oem one from my local dealer tomorrow. I’ll post a picture of the difference in sizes

Share this post


Link to post
Share on other sites
13 hours ago, Nso93 said:

Just a little heads the ultra racing brace isn’t a direct replacement as it’s not long enough. I’m picking up a oem one from my local dealer tomorrow. I’ll post a picture of the difference in sizes

As promised a picture of the size difference 

E0CDBBE2-2545-44DB-83CD-1D50C8903E51.jpeg

Share this post


Link to post
Share on other sites
5 hours ago, nissanjuke said:

as long as they do the job, no :thumbs:worries

Wouldn’t recommend the ultra racing. Looks like a brace possibly for the front 

Share this post


Link to post
Share on other sites

Small issue with the removal of the old brace. The bolts had corroded around the heads and snapped off with any amount of pressure. In the end the rear axle carrier mounts had corroded and also need replacing. 

 

The cars been sat at litchfield imports now since last Thursday awaiting the new parts to arrive from Japan. 

 

 

8B46043D-077C-4409-BEC7-6E49939B3E9F.jpeg

1CE1C28E-553C-4147-8492-DACAC997B289.jpeg

Edited by Nso93

Share this post


Link to post
Share on other sites

We had 3 boys swinging from mine to try get it off :lol: took about 4hrs all in I think. Content soaking of the old bolts 

Share this post


Link to post
Share on other sites
1 hour ago, PPod said:

We had 3 boys swinging from mine to try get it off :lol: took about 4hrs all in I think. Content soaking of the old bolts 

Took 2 and half to remove all the old parts. Just a long wait for the last couple of peices to turn up. Mine left a rust pile on the floor.

  • Haha 1

Share this post


Link to post
Share on other sites

How did you get that ebay disc to work, i bought the exact same disc stuck it in the dvd/cd player in the front and it just got stuck saying it was loading over and over

Share this post


Link to post
Share on other sites

my car is 2009model and the DVD map player is behind my seat, not at the front console.

 

it's behind the driver's seat.:thumbs:

Share this post


Link to post
Share on other sites

I might go looking there because the disc just wont work for me, maybe there's a second disc drive

Share this post


Link to post
Share on other sites

Can’t believe how bad that original W brace has gone, I think you caught it just in time

keep up the good work :)

Share this post


Link to post
Share on other sites
1 hour ago, Jonnymonno said:

Can’t believe how bad that original W brace has gone, I think you caught it just in time

keep up the good work :)

Cheers mate. Hopefully get it back next week. Been along two weeks so far

Share this post


Link to post
Share on other sites
1 hour ago, valy said:

good news , fancy a convoy to Cross Point meet this Sunday ? :teeth:

Can’t make this meet mate. But I hope to see you car soon looks good in the pictures 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×