Jump to content
Sign in to follow this  
Terence Bower

Traction control switch

Recommended Posts

Silly question but as I have mislaid my drivers handbook!!

When switched off,so the dash warning light comes on as it should.Now yesterday,had to remove the rigth hand front caliper for servicing,during the time it was off I switched the ignition on but did not touch the tc switch but the warning light plus the other sliding car lamp came on.This surprised me as I have never seen it before.

I assume it to be something to do with the brake circuit being broken,is this so?Everthing back to normal now its all together again.Should both of those lights come on when the tc switch is switched off?

Thanks in advance.

Share this post


Link to post
Share on other sites

Sounds about right. Without the front caliper the stability control is effectively unable to operate, so I would expect to see the tcs warning and another warning.

Share this post


Link to post
Share on other sites

Thank you but if the tc switch is off,should I see both amber lights illuminated?Reason I ask is that turning tc off makes barely any difference.Tried the usual stuff in case the diff is just not playing and needs replacing.

Share this post


Link to post
Share on other sites

I had a very similar issue when I replaced my brake lines. Got to the drivers rear line and snapped it at the union as it had seized. Wasnt overly bothed as I knew I could get it trailered down to the shop. Obviously I had no brakes due to the snapped line, but thought I could at least move it on the drive. Nope

 

Not sure exactly what it was, but the car sensed the lack of brake fluid, threw up both warning lights that you have and locked the differential meaning the car, even under its own power wouldnt move. It was like the handbrake was on.

 

Im not sure how related both of these are, but thought I'd offer my input. Did you disconnect the lines?

Share this post


Link to post
Share on other sites

Yes,very similar to what you had.Problem is I cannot get to the bottom of my diff issue.Visual inspection,cover off,all looks to be in order(didnt have time to remove it) no noises from it ,new oil but no lsd properties with the switch off😠

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

350z-uk.com

370z-uk.com

×
×
  • Create New...